Back to overview
Downtime
Some services are down
May 02 at 03:01am CEST
Affected services
Main Website (flexynode.com)
Resolved
May 02 at 11:24am CEST
Everything is resolved.
Affected services
Main Website (flexynode.com)
Created
May 02 at 03:01am CEST
FlexyNode.com is currently unavailable due to technical issues with our hosting provider's server. We apologize for any inconvenience this may cause. Updates will be provided as soon as they are available. Thank you for your patience and understanding.
Affected services
Main Website (flexynode.com)